CVE-2020-1730

NameCVE-2020-1730
DescriptionA flaw was found in libssh versions before 0.8.9 and before 0.9.4 in the way it handled AES-CTR (or DES ciphers if enabled) ciphers. The server or client could crash when the connection hasn't been fully initialized and the system tries to cleanup the ciphers when closing the connection. The biggest threat from this vulnerability is system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs956308

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libssh (PTS)jessie0.6.3-4+deb8u2fixed
jessie (security)0.6.3-4+deb8u4fixed
stretch0.7.3-2+deb9u2fixed
stretch (security)0.7.3-2+deb9u1fixed
buster0.8.7-1+deb10u1fixed
bullseye, sid0.9.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsshsource(unstable)0.9.4-1956308
libsshsourcebuster0.8.7-1+deb10u1
libsshsourcejessie(not affected)
libsshsourcestretch(not affected)

Notes

[stretch] - libssh <not-affected> (Vulnerable code introduced later)
[jessie] - libssh <not-affected> (Vulnerable code introduced later)
https://www.libssh.org/security/advisories/CVE-2020-1730.txt
https://bugs.libssh.org/T213
Introduced by: https://git.libssh.org/projects/libssh.git/commit/?id=84a85803b4c83b8dac03b0d0aba58b48c98253e6 (libssh-0.8.0)
Fixed by: https://git.libssh.org/projects/libssh.git/commit/?id=b36272eac1b36982598c10de7af0a501582de07a

Search for package or bug name: Reporting problems