CVE-2020-17353

NameCVE-2020-17353
Descriptionscm/define-stencil-commands.scm in LilyPond through 2.20.0, and 2.21.x through 2.21.4, when -dsafe is used, lacks restrictions on embedded-ps and embedded-svg, as demonstrated by including dangerous PostScript code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4756-1
NVD severityhigh
Debian Bugs968993

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lilypond (PTS)buster, buster (security)2.19.81+really-2.18.2-13+deb10u1fixed
bullseye, sid2.20.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lilypondsourcebuster2.19.81+really-2.18.2-13+deb10u1DSA-4756-1
lilypondsource(unstable)2.20.0-2968993

Notes

http://git.savannah.gnu.org/gitweb/?p=lilypond.git;a=commit;h=b84ea4740f3279516905c5db05f4074e777c16ff

Search for package or bug name: Reporting problems