DescriptionLilyPond before 2.24 allows attackers to bypass the -dsafe protection mechanism via output-def-lookup or output-def-scope, as demonstrated by dangerous Scheme code in a .ly file that causes arbitrary code execution during conversion to a different file format. NOTE: in 2.24 and later versions, safe mode is removed, and the product no longer tries to block code execution when external files are used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lilypond (PTS)buster, buster (security)2.19.81+really-2.18.2-13+deb10u1vulnerable
sid, trixie2.24.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bullseye] - lilypond <ignored> (Unfixable, marked as insecure in later uploads)
[buster] - lilypond <ignored> (Unfixable, marked as insecure in later uploads)
2.22.1-1 adds a note about Lilypond security status, using that the "fixed" version

Search for package or bug name: Reporting problems