CVE-2020-1747

NameCVE-2020-1747
DescriptionA vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. An attacker could use this flaw to execute arbitrary code on the system by abusing the python/object/new constructor.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs953013

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pyyaml (PTS)stretch3.12-1fixed
buster3.13-2fixed
bullseye, sid5.3.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pyyamlsourcejessie(not affected)
pyyamlsourcestretch(not affected)
pyyamlsourcebuster(not affected)
pyyamlsource(unstable)5.3-2953013

Notes

[buster] - pyyaml <not-affected> (Loader/Constructor classes are unsafe in this version)
[stretch] - pyyaml <not-affected> (Loader/Constructor classes are unsafe in this version)
[jessie] - pyyaml <not-affected> (Loader/Constructor classes are unsafe in this version)
https://github.com/yaml/pyyaml/pull/386

Search for package or bug name: Reporting problems