CVE-2020-1773

NameCVE-2020-1773
DescriptionAn attacker with the ability to generate session IDs or password reset tokens, either by being able to authenticate or by exploiting OSA-2020-09, may be able to predict other users session IDs, password reset tokens and automatically generated passwords. This issue affects ((OTRS)) Community Edition: 5.0.41 and prior versions, 6.0.26 and prior versions. OTRS; 7.0.15 and prior versions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
otrs2 (PTS)buster/non-free6.0.16-2vulnerable
bullseye/non-free, sid/non-free6.0.30-1fixed
stretch/non-free (security), stretch/non-free5.0.16-1+deb9u6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
otrs2source(unstable)6.0.27-1

Notes

[buster] - otrs2 <no-dsa> (Non-free not supported)
[stretch] - otrs2 <no-dsa> (Non-free not supported)
[jessie] - otrs2 <no-dsa> (Too intrusive to backport)
https://otrs.com/release-notes/otrs-security-advisory-2020-10/
Fixed in 7.0.16, 6.0.27, 5.0.42
OTRS6: https://github.com/OTRS/otrs/commit/ab253734bc211541309b9f8ea2b8b70389c4a64e
OTRS5: https://github.com/OTRS/otrs/commit/4955521af50238046847bce51ad9865950324f77

Search for package or bug name: Reporting problems