CVE-2020-18185

NameCVE-2020-18185
Descriptionclass.plx.admin.php in PluXml 5.7 allows attackers to execute arbitrary PHP code by modify the configuration file in a linux environment.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs973382

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pluxml (PTS)stretch5.5-2vulnerable
sid, buster5.6-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pluxmlsource(unstable)(unfixed)unimportant973382

Notes

https://github.com/pluxml/PluXml/issues/321
The attack vector is a little unusual but it would be quite expected that
the admin can execute arbitrary php code.

Search for package or bug name: Reporting problems