CVE-2020-18671

NameCVE-2020-18671
DescriptionCross Site Scripting (XSS) vulnerability in Roundcube Mail <=1.4.4 via smtp config in /installer/test.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
roundcube (PTS)stretch1.2.3+dfsg.1-4+deb9u6vulnerable
stretch (security)1.2.3+dfsg.1-4+deb9u8vulnerable
buster, buster (security)1.3.16+dfsg.1-1~deb10u1fixed
bookworm, sid, bullseye1.4.11+dfsg.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
roundcubesourcebuster1.3.13+dfsg.1-1~deb10u1
roundcubesource(unstable)1.4.5+dfsg.1-1

Notes

[stretch] - roundcube <postponed> (Minor issue, XSS in installer which is not exposed in Debian)
https://github.com/roundcube/roundcubemail/issues/7406
https://roundcube.net/news/2020/06/02/security-updates-1.4.5-and-1.3.12

Search for package or bug name: Reporting problems