CVE-2020-1931

NameCVE-2020-1931
DescriptionA command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious Configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. This issue is less stealthy and attempts to exploit the issue will throw warnings. Thanks to Damian Lukowski at credativ for reporting the issue ethically. With this bug unpatched, exploits can be injected in a number of scenarios though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2107-1, DSA-4615-1
NVD severityhigh
Debian Bugs950258

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spamassassin (PTS)stretch (security), stretch3.4.2-1~deb9u3fixed
buster, buster (security)3.4.2-1+deb10u2fixed
bullseye, sid3.4.5~pre1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spamassassinsourcejessie3.4.2-0+deb8u3DLA-2107-1
spamassassinsourcestretch3.4.2-1~deb9u3DSA-4615-1
spamassassinsourcebuster3.4.2-1+deb10u2DSA-4615-1
spamassassinsource(unstable)3.4.4~rc1-1950258

Notes

https://svn.apache.org/repos/asf/spamassassin/branches/3.4/build/announcements/3.4.4.txt
https://www.openwall.com/lists/oss-security/2020/01/30/2
https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7784 (restricted)

Search for package or bug name: Reporting problems