CVE-2020-1941

NameCVE-2020-1941
DescriptionIn Apache ActiveMQ 5.0.0 to 5.15.11, the webconsole admin GUI is open to XSS, in the view that lists the contents of a queue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
activemq (PTS)stretch5.14.3-3vulnerable
stretch (security)5.14.3-3+deb9u1vulnerable
buster5.15.8-2vulnerable
bullseye, sid5.16.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
activemqsource(unstable)(unfixed)unimportant

Notes

Admin console not enabled in the Debian package, see #702670)
Fixed in 5.15.12

Search for package or bug name: Reporting problems