CVE-2020-1957

NameCVE-2020-1957
DescriptionApache Shiro before 1.5.2, when using Apache Shiro with Spring dynamic controllers, a specially crafted request may cause an authentication bypass.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2181-1, DLA-2273-1
NVD severityhigh
Debian Bugs955018

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shiro (PTS)stretch1.3.2-1vulnerable
stretch (security)1.3.2-1+deb9u2fixed
buster, bullseye1.3.2-4vulnerable
bookworm, sid1.3.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shirosourcejessie1.2.3-1+deb8u1DLA-2181-1
shirosourcestretch1.3.2-1+deb9u1DLA-2273-1
shirosource(unstable)1.3.2-5955018

Notes

[bullseye] - shiro <no-dsa> (Minor issue)
[buster] - shiro <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2020/03/23/2
Fixed by: https://github.com/apache/shiro/commit/3708d7907016bf2fa12691dff6ff0def1249b8ce#diff-98f7bc5c0391389e56531f8b3754081aL139
https://github.com/apache/shiro/pull/203#issuecomment-606270322
Fix for CVE-2020-1957 introduces a (security sensitive) encoding issue
resulting in a followup release 1.5.3.

Search for package or bug name: Reporting problems