CVE-2020-21041

NameCVE-2020-21041
DescriptionBuffer Overflow vulnerability exists in FFmpeg 4.1 via apng_do_inverse_blend in libavcodec/pngenc.c, which could let a remote malicious user cause a Denial of Service
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2742-1, DSA-4990-1
NVD severitymedium
Debian Bugs989439

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1vulnerable
stretch (security)7:3.2.16-1+deb9u1fixed
buster7:4.1.6-1~deb10u1vulnerable
buster (security)7:4.1.8-0+deb10u1fixed
bullseye7:4.3.2-0+deb11u2fixed
bullseye (security)7:4.3.3-0+deb11u1fixed
bookworm, sid7:4.4.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourceexperimental7:4.4-1
ffmpegsourcestretch7:3.2.15-0+deb9u3DLA-2742-1
ffmpegsourcebuster7:4.1.8-0+deb10u1DSA-4990-1
ffmpegsource(unstable)7:4.3.2-0+deb11u2989439

Notes

[stretch] - ffmpeg <postponed> (Wait for 4.1.9)
https://trac.ffmpeg.org/ticket/7989
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=5d9f44da460f781a1604d537d0555b78e29438ba

Search for package or bug name: Reporting problems