CVE-2020-22040

NameCVE-2020-22040
DescriptionA Denial of Service vulnerability exists in FFmpeg 4.2 idue to a memory leak in the v_frame_alloc function in frame.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.14-1~deb9u1vulnerable
stretch (security)7:3.2.18-0+deb9u1vulnerable
buster7:4.1.8-0+deb10u1vulnerable
buster (security)7:4.1.9-0+deb10u1vulnerable
bullseye7:4.3.3-0+deb11u1fixed
bullseye (security)7:4.3.4-0+deb11u1fixed
sid, bookworm7:4.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:4.3-2unimportant

Notes

[stretch] - ffmpeg <ignored> (Patch can not be applied cleanly; Minor issue)
https://trac.ffmpeg.org/ticket/8283
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=1a0c584abc9709b1d11dbafef05d22e0937d7d19

Search for package or bug name: Reporting problems