CVE-2020-22054

NameCVE-2020-22054
DescriptionA Denial of Service vulnerability exists in FFmpeg 4.2 due to a memory leak in the av_dict_set function in dict.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2818-1, DSA-4990-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)buster7:4.1.8-0+deb10u1fixed
buster (security)7:4.1.9-0+deb10u1fixed
bullseye7:4.3.3-0+deb11u1fixed
bullseye (security)7:4.3.4-0+deb11u1fixed
bookworm, sid7:5.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcestretch7:3.2.16-1+deb9u1DLA-2818-1
ffmpegsourcebuster7:4.1.8-0+deb10u1DSA-4990-1
ffmpegsource(unstable)7:4.3-2unimportant

Notes

https://trac.ffmpeg.org/ticket/8315
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=6f2a3958cfac135c60b509a61a4fd39432d8f9a9
Negligible security impact

Search for package or bug name: Reporting problems