CVE-2020-22570

NameCVE-2020-22570
DescriptionMemcached 1.6.0 before 1.6.3 allows remote attackers to cause a denial of service (daemon crash) via a crafted meta command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
memcached (PTS)buster1.5.6-1.1fixed
buster (security)1.5.6-1.1+deb10u1fixed
bullseye1.6.9+dfsg-1fixed
bookworm1.6.18-1fixed
sid, trixie1.6.23-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
memcachedsourcebuster(not affected)
memcachedsource(unstable)1.6.3-1

Notes

[buster] - memcached <not-affected> (Vulnerable code not present)
https://github.com/memcached/memcached/issues/636
Fixed by: https://github.com/memcached/memcached/commit/f249724cedcab6605ca8a0769ac4b356a8124f63 (1.6.3)

Search for package or bug name: Reporting problems