CVE-2020-23309

NameCVE-2020-23309
DescriptionThere is an Assertion 'context_p->stack_depth == context_p->context_stack_depth' failed at js-parser-statm.c:2756 in parser_parse_statements in JerryScript 2.2.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs989991

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iotjs (PTS)buster1.0-1vulnerable
bookworm, sid, bullseye1.0+715-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iotjssource(unstable)(unfixed)989991

Notes

[bullseye] - iotjs <no-dsa> (Minor issue)
[buster] - iotjs <no-dsa> (Minor issue)
https://github.com/jerryscript-project/jerryscript/issues/3820

Search for package or bug name: Reporting problems