CVE-2020-23914

NameCVE-2020-23914
DescriptionAn issue was discovered in cpp-peglib through v0.1.12. A NULL pointer dereference exists in the peg::AstOptimizer::optimize() located in peglib.h. It allows an attacker to cause Denial of Service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
retroarch (PTS)buster1.7.3+dfsg1-1vulnerable
bullseye1.7.3+dfsg1-1.1vulnerable
bookworm1.14.0+dfsg-1vulnerable
trixie, sid1.16.0.3+dfsg-1vulnerable
salmon (PTS)buster0.12.0+ds1-1fixed
bullseye1.4.0+ds1-1fixed
bookworm1.10.1+ds1-1fixed
trixie, sid1.10.2+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
retroarchsource(unstable)(unfixed)unimportant
salmonsource(unstable)(not affected)

Notes

peglib.h is not compiled in Debian builds
- salmon <not-affected> (Vulnerable code never in a released Debian version)
Crash in CLI tool, no security impact
https://github.com/yhirose/cpp-peglib/commit/0061f393de54cf0326621c079dc2988336d1ebb3
https://github.com/yhirose/cpp-peglib/issues/121

Search for package or bug name: Reporting problems