CVE-2020-24266

NameCVE-2020-24266
DescriptionAn issue was discovered in tcpreplay tcpprep v4.3.3. There is a heap buffer overflow vulnerability in get_l2len() that can make tcpprep crash and cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs972889

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpreplay (PTS)stretch3.4.4-3vulnerable
buster4.3.1-1vulnerable
bullseye, sid4.3.3-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpreplaysource(unstable)(unfixed)unimportant972889

Notes

https://github.com/appneta/tcpreplay/issues/617
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems