CVE-2020-24370

NameCVE-2020-24370
Descriptionldebug.c in Lua 5.4.0 allows a negation overflow and segmentation fault in getlocal and setlocal, as demonstrated by getlocal(3,2^31).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2381-1
NVD severitymedium
Debian Bugs971613

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lua5.3 (PTS)stretch5.3.3-1vulnerable
stretch (security)5.3.3-1+deb9u1fixed
bullseye, sid, buster5.3.3-1.1vulnerable
lua5.4 (PTS)bullseye, sid5.4.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lua5.3sourcestretch5.3.3-1+deb9u1DLA-2381-1
lua5.3source(unstable)(unfixed)
lua5.4source(unstable)(unfixed)971613

Notes

[buster] - lua5.3 <no-dsa> (Minor issue)
http://lua-users.org/lists/lua-l/2020-07/msg00324.html
(lua5.4) https://github.com/lua/lua/commit/a585eae6e7ada1ca9271607a4f48dfb17868ab7b
(lua5.3) https://github.com/lua/lua/commit/b5bc89846721375fe30772eb8c5ab2786f362bf9

Search for package or bug name: Reporting problems