CVE-2020-24394

NameCVE-2020-24394
DescriptionIn the Linux kernel before 5.7.8, fs/nfsd/vfs.c (in the NFS server) can set incorrect permissions on new filesystem objects when the filesystem lacks ACL support, aka CID-22cf8419f131. This occurs because the current umask is not considered.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs962254

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.210-1+deb9u1fixed
buster4.19.146-1fixed
buster (security)4.19.152-1fixed
bullseye, sid5.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch(not affected)
linuxsourcebuster4.19.131-1
linuxsource(unstable)5.7.6-1962254

Notes

[stretch] - linux <not-affected> (Vulnerable code introduced later)
https://git.kernel.org/linus/22cf8419f1319ff87ec759d0ebdff4cbafaee832

Search for package or bug name: Reporting problems