CVE-2020-24553

NameCVE-2020-24553
DescriptionGo before 1.14.8 and 1.15.x before 1.15.1 allows XSS because text/html is the default for CGI/FCGI handlers that lack a Content-Type header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs969661, 969662

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u3vulnerable
golang-1.14 (PTS)bullseye, sid1.14.7-2vulnerable
golang-1.15 (PTS)bullseye, sid1.15.2-1fixed
golang-1.7 (PTS)stretch (security), stretch1.7.4-2+deb9u1vulnerable
golang-1.8 (PTS)stretch (security), stretch1.8.1-1+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-1.11source(unstable)(unfixed)
golang-1.14source(unstable)(unfixed)969662
golang-1.15source(unstable)1.15.2-1969661
golang-1.7source(unstable)(unfixed)
golang-1.8source(unstable)(unfixed)

Notes

[buster] - golang-1.11 <no-dsa> (Minor issue)
https://groups.google.com/forum/#!topic/golang-announce/8wqlSbkLdPs
https://github.com/golang/go/issues/40928
https://github.com/golang/go/issues/41164 (1.14 backport)
https://github.com/golang/go/issues/41165 (1.15 backport)
https://www.redteam-pentesting.de/en/advisories/rt-sa-2020-004/-inconsistent-behavior-of-gos-cgi-and-fastcgi-transport-may-lead-to-cross-site-scripting

Search for package or bug name: Reporting problems