CVE-2020-24584

NameCVE-2020-24584
DescriptionAn issue was discovered in Django 2.2 before 2.2.16, 3.0 before 3.0.10, and 3.1 before 3.1.1 (when Python 3.7+ is used). The intermediate-level directories of the filesystem cache had the system's standard umask rather than 0o077.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs969367

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)stretch (security), stretch1:1.10.7-2+deb9u9fixed
buster, buster (security)1:1.11.29-1~deb10u1vulnerable
bullseye, sid2:2.2.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcestretch(not affected)
python-djangosource(unstable)2:2.2.16-1969367

Notes

[buster] - python-django <postponed> (Fix along in future DSA)
[stretch] - python-django <not-affected> (Requires Python 3.7+)
https://github.com/django/django/commit/1853724acaf17ed7414d54c7d2b5563a25025a71 (master)
https://github.com/django/django/commit/2b099caa5923afa8cfb5f1e8c0d56b6e0e81915b (3.1.1)
https://github.com/django/django/commit/cdb367c92a0ba72ddc0cbd13ff42b0e6df709554 (3.0.10)
https://github.com/django/django/commit/a3aebfdc8153dc230686b6d2454ccd32ed4c9e6f (2.2.16)

Search for package or bug name: Reporting problems