CVE-2020-24614

NameCVE-2020-24614
DescriptionFossil before 2.10.2, 2.11.x before 2.11.2, and 2.12.x before 2.12.1 allows remote authenticated users to execute arbitrary code. An attacker must have check-in privileges on the repository.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fossil (PTS)stretch1:1.37-1vulnerable
buster1:2.8-1vulnerable
bullseye, sid1:2.12.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fossilsource(unstable)1:2.12.1-1

Notes

[buster] - fossil <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2020/08/20/1
https://fossil-scm.org/forum/info/a05ae3ce7760daf6
https://fossil-scm.org/fossil/vdiff?branch=sec2020-2.12-patch&diff=1&w

Search for package or bug name: Reporting problems