CVE-2020-24890

NameCVE-2020-24890
Descriptionlibraw 20.0 has a null pointer dereference vulnerability in parse_tiff_ifd in src/metadata/tiff.cpp, which may result in context-dependent arbitrary code execution. Note: this vulnerability occurs only if you compile the software in a certain way
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)buster0.19.2-2vulnerable
buster (security)0.19.2-2+deb10u4vulnerable
bullseye (security), bullseye0.20.2-1+deb11u1vulnerable
bookworm0.20.2-2.1vulnerable
sid, trixie0.21.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)(unfixed)unimportant

Notes

https://github.com/LibRaw/LibRaw/issues/335
https://github.com/LibRaw/LibRaw/issues/335#issuecomment-677637276

Search for package or bug name: Reporting problems