CVE-2020-25592

NameCVE-2020-25592
DescriptionIn SaltStack Salt through 3002, salt-netapi improperly validates eauth credentials and tokens. A user can bypass authentication and invoke Salt SSH.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2480-1, DSA-4837-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
salt (PTS)stretch2016.11.2+ds-1+deb9u4vulnerable
stretch (security)2016.11.2+ds-1+deb9u9fixed
buster2018.3.4+dfsg1-6+deb10u2fixed
buster (security)2018.3.4+dfsg1-6+deb10u3fixed
bullseye3002.6+dfsg1-4fixed
bullseye (security)3002.6+dfsg1-4+deb11u1fixed
bookworm, sid3004+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
saltsourcestretch2016.11.2+ds-1+deb9u6DLA-2480-1
saltsourcebuster2018.3.4+dfsg1-6+deb10u2DSA-4837-1
saltsource(unstable)3002.1+dfsg1-1

Notes

https://www.saltstack.com/blog/on-november-3-2020-saltstack-publicly-disclosed-three-new-cves/
https://gitlab.com/saltstack/open/salt-patches/-/raw/master/patches/2020/09/25/2018.3.5.patch (2018.3.5)
https://gitlab.com/saltstack/open/salt-patches/-/raw/master/patches/2020/09/25/2016.11.3.patch (2016.11.3)

Search for package or bug name: Reporting problems