CVE-2020-25648

NameCVE-2020-25648
DescriptionA flaw was found in the way NSS handled CCS (ChangeCipherSpec) messages in TLS 1.3. This flaw allows a remote attacker to send multiple CCS messages, causing a denial of service for servers compiled with the NSS library. The highest threat from this vulnerability is to system availability. This flaw affects NSS versions before 3.58.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss (PTS)stretch2:3.26.2-1.1+deb9u1vulnerable
stretch (security)2:3.26.2-1.1+deb9u2vulnerable
buster, buster (security)2:3.42.1-1+deb10u3vulnerable
bullseye, sid2:3.61-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nsssource(unstable)2:3.58-1

Notes

[buster] - nss <no-dsa> (Minor issue)
[stretch] - nss <no-dsa> (Minor issue)
https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.58_release_notes
https://bugzilla.mozilla.org/show_bug.cgi?id=1641480 (private)
Fixed by: https://hg.mozilla.org/projects/nss/rev/57bbefa793232586d27cee83e74411171e128361

Search for package or bug name: Reporting problems