CVE-2020-25814

NameCVE-2020-25814
DescriptionIn MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a> tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2379-1, DSA-4767-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3vulnerable
stretch (security)1:1.27.7-1~deb9u5fixed
buster1:1.31.7-1~deb10u1vulnerable
buster (security)1:1.31.10-1~deb10u1fixed
bullseye, sid1:1.35.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcestretch1:1.27.7-1~deb9u4DLA-2379-1
mediawikisourcebuster1:1.31.10-1~deb10u1DSA-4767-1
mediawikisource(unstable)1:1.35.0-1

Notes

https://lists.wikimedia.org/pipermail/wikitech-l/2020-September/093888.html
https://phabricator.wikimedia.org/T86738

Search for package or bug name: Reporting problems