CVE-2020-26154

NameCVE-2020-26154
Descriptionurl.cpp in libproxy through 0.4.15 is prone to a buffer overflow when PAC is enabled, as demonstrated by a large PAC file that is delivered without a Content-length header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2450-1, DSA-4800-1
Debian Bugs968366

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libproxy (PTS)buster, buster (security)0.4.15-5+deb10u1fixed
bullseye0.4.17-1fixed
bookworm0.4.18-1.2fixed
sid, trixie0.5.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libproxysourcestretch0.4.14-2+deb9u2DLA-2450-1
libproxysourcebuster0.4.15-5+deb10u1DSA-4800-1
libproxysource(unstable)0.4.15-15968366

Notes

https://github.com/libproxy/libproxy/pull/126
https://github.com/libproxy/libproxy/commit/4411b523545b22022b4be7d0cac25aa170ae1d3e

Search for package or bug name: Reporting problems