CVE-2020-26571

NameCVE-2020-26571
DescriptionThe gemsafe GPK smart card software driver in OpenSC before 0.21.0-rc1 has a stack-based buffer overflow in sc_pkcs15emu_gemsafeGPK_init.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2832-1
Debian Bugs972036

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensc (PTS)buster0.19.0-1+deb10u1fixed
bullseye0.21.0-1fixed
bookworm, sid0.22.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openscsourcestretch0.16.0-3+deb9u2DLA-2832-1
openscsourcebuster0.19.0-1+deb10u1
openscsource(unstable)0.21.0-1972036

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=20612
https://github.com/OpenSC/OpenSC/commit/ed55fcd2996930bf58b9bb57e9ba7b1f3a753c43 (0.21.0-rc1)

Search for package or bug name: Reporting problems