DescriptionThe JWT library in NATS nats-server before 2.1.9 has Incorrect Access Control because of how expired credentials are handled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs988950

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-github-nats-io-jwt (PTS)bookworm2.3.0-1fixed
sid, trixie2.5.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[buster] - golang-github-nats-io-jwt <postponed> (Limited support, minor issue, requires rebuilding golang-github-nats-io-gnatsd)

Search for package or bug name: Reporting problems