CVE-2020-26950

NameCVE-2020-26950
DescriptionIn certain circumstances, the MCallGetProperty opcode can be emitted with unmet assumptions resulting in an exploitable use-after-free condition. This vulnerability affects Firefox < 82.0.3, Firefox ESR < 78.4.1, and Thunderbird < 78.4.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2448-1, DLA-2449-1, DSA-4788-1, DSA-4790-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid127.0-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1fixed
buster (security)115.12.0esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.12.0esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.12.0esr-1~deb12u1fixed
trixie115.11.0esr-1fixed
sid115.12.0esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1fixed
buster (security)1:115.11.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.11.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.11.0-1~deb12u1fixed
sid, trixie1:115.11.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)82.0.3-1
firefox-esrsourcestretch78.4.1esr-1~deb9u1DLA-2448-1
firefox-esrsourcebuster78.4.1esr-1~deb10u1DSA-4788-1
firefox-esrsource(unstable)78.4.1esr-1
thunderbirdsourcestretch1:78.4.2-1~deb9u1DLA-2449-1
thunderbirdsourcebuster1:78.4.2-1~deb10u1DSA-4790-1
thunderbirdsource(unstable)1:78.4.2-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-49/#CVE-2020-26950

Search for package or bug name: Reporting problems