CVE-2020-27671

NameCVE-2020-27671
DescriptionAn issue was discovered in Xen through 4.14.x allowing x86 HVM and PVH guest OS users to cause a denial of service (data corruption), cause a data leak, or possibly gain privileges because coalescing of per-page IOMMU TLB flushes is mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4804-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12vulnerable
buster4.11.4+99-g8bce4698f6-1fixed
buster (security)4.11.4+107-gef32c7afa2-1fixed
bullseye4.14.1+11-gb0b734a8b3-1fixed
sid4.14.2+25-gb6a8c4f72d-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcestretch(unfixed)end-of-life
xensourcebuster4.11.4+57-g41a822c392-1DSA-4804-1
xensource(unstable)4.14.0+80-gd101b417b7-1

Notes

[stretch] - xen <end-of-life> (DSA 4602-1)
https://xenbits.xen.org/xsa/advisory-346.html

Search for package or bug name: Reporting problems