DescriptionExim 4 before 4.94.2 allows an off-by-two Out-of-bounds Write because "-F ''" is mishandled by parse_fix_phrase.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)stretch4.89-2+deb9u7fixed
stretch (security)4.89-2+deb9u8fixed
buster, buster (security)4.92-8+deb10u6fixed
bullseye, sid4.94.2-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4sourcestretch(not affected)
exim4sourcebuster(not affected)


[buster] - exim4 <not-affected> (Vulnerable code introduced later)
[stretch] - exim4 <not-affected> (Vulnerable code introduced later)
Introduced by:

Search for package or bug name: Reporting problems