CVE-2020-28018

NameCVE-2020-28018
DescriptionExim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common for builds with OpenSSL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)stretch4.89-2+deb9u7fixed
stretch (security)4.89-2+deb9u8fixed
buster4.92-8+deb10u5vulnerable
buster (security)4.92-8+deb10u6fixed
bullseye4.94.2-1fixed
sid4.94.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4sourcestretch(not affected)
exim4sourcebuster4.92-8+deb10u6
exim4source(unstable)4.94.2-1unimportant

Notes

[stretch] - exim4 <not-affected> (Vulnerable code introduced later)
Introduced by: https://git.exim.org/exim.git/commit/a5ffa9b475a426bc73366db01f7cc92a3811bc3a (exim-4_90_RC1)
Debian Exim is built with GnuTLS, not OpenSSL.
https://www.openwall.com/lists/oss-security/2021/05/04/7

Search for package or bug name: Reporting problems