CVE-2020-28037

NameCVE-2020-28037
Descriptionis_blog_installed in wp-includes/functions.php in WordPress before 5.5.2 improperly determines whether WordPress is already installed, which might allow an attacker to perform a new installation, leading to remote code execution (as well as a denial of service for the old installation).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2429-1, DSA-4784-1
Debian Bugs973562

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)buster5.0.15+dfsg1-0+deb10u1fixed
buster (security)5.0.18+dfsg1-0+deb10u1fixed
bullseye5.7.5+dfsg1-0+deb11u1fixed
bullseye (security)5.7.8+dfsg1-0+deb11u2fixed
bookworm6.0.3+dfsg1-1fixed
sid6.1+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcestretch4.7.19+dfsg-1+deb9u1DLA-2429-1
wordpresssourcebuster5.0.11+dfsg1-0+deb10u1DSA-4784-1
wordpresssource(unstable)5.5.3+dfsg1-1973562

Notes

https://github.com/WordPress/wordpress-develop/commit/2ca15d1e5ce70493c5c0c096ca0c76503d6da07c
https://wordpress.org/news/2020/10/wordpress-5-5-2-security-and-maintenance-release/
https://wpscan.com/vulnerability/10450

Search for package or bug name: Reporting problems