CVE-2020-28039

NameCVE-2020-28039
Descriptionis_protected_meta in wp-includes/meta.php in WordPress before 5.5.2 allows arbitrary file deletion because it does not properly determine whether a meta key is considered protected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2429-1, DSA-4784-1
NVD severitymedium
Debian Bugs973562

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch4.7.5+dfsg-2+deb9u6vulnerable
stretch (security)4.7.19+dfsg-1+deb9u1fixed
buster5.0.10+dfsg1-0+deb10u1vulnerable
buster (security)5.0.11+dfsg1-0+deb10u1fixed
bullseye5.5.1+dfsg1-1vulnerable
sid5.5.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcestretch4.7.19+dfsg-1+deb9u1DLA-2429-1
wordpresssourcebuster5.0.11+dfsg1-0+deb10u1DSA-4784-1
wordpresssource(unstable)5.5.3+dfsg1-1973562

Notes

https://github.com/WordPress/wordpress-develop/commit/d5ddd6d4be1bc9fd16b7796842e6fb26315705ad
https://wordpress.org/news/2020/10/wordpress-5-5-2-security-and-maintenance-release/
https://wpscan.com/vulnerability/10452

Search for package or bug name: Reporting problems