CVE-2020-28196

NameCVE-2020-28196
DescriptionMIT Kerberos 5 (aka krb5) before 1.17.2 and 1.18.x before 1.18.3 allows unbounded recursion via an ASN.1-encoded Kerberos message because the lib/krb5/asn.1/asn1_encode.c support for BER indefinite lengths lacks a recursion limit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2437-1, DSA-4795-1
NVD severitymedium
Debian Bugs973880

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)stretch1.15-1+deb9u1vulnerable
stretch (security)1.15-1+deb9u2fixed
buster1.17-3vulnerable
buster (security)1.17-3+deb10u1fixed
bullseye, sid1.18.3-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourceexperimental1.18.2-1
krb5sourcestretch1.15-1+deb9u2DLA-2437-1
krb5sourcebuster1.17-3+deb10u1DSA-4795-1
krb5source(unstable)1.18.3-1973880

Notes

https://github.com/krb5/krb5/commit/57415dda6cf04e73ffc3723be518eddfae599bfd

Search for package or bug name: Reporting problems