CVE-2020-28241

NameCVE-2020-28241
Descriptionlibmaxminddb before 1.4.3 has a heap-based buffer over-read in dump_entry_data_list in maxminddb.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2445-1
NVD severitymedium
Debian Bugs973878

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmaxminddb (PTS)stretch1.2.0-1vulnerable
stretch (security)1.2.0-1+deb9u1fixed
bullseye, sid, buster1.3.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmaxminddbsourcestretch1.2.0-1+deb9u1DLA-2445-1
libmaxminddbsource(unstable)(unfixed)973878

Notes

[buster] - libmaxminddb <no-dsa> (Minor issue)
https://github.com/maxmind/libmaxminddb/issues/236
https://github.com/maxmind/libmaxminddb/pull/237

Search for package or bug name: Reporting problems