DescriptionGo before 1.14.12 and 1.15.x before 1.15.4 allows Denial of Service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u4fixed
golang-1.15 (PTS)bullseye1.15.9-6fixed
bookworm, sid1.15.15-4fixed
golang-1.7 (PTS)stretch1.7.4-2+deb9u1fixed
stretch (security)1.7.4-2+deb9u3fixed
golang-1.8 (PTS)stretch1.8.1-1+deb9u1fixed
stretch (security)1.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-1.11source(unstable)(not affected)
golang-1.7source(unstable)(not affected)
golang-1.8source(unstable)(not affected)


- golang-1.11 <not-affected> (Vulnerable code introduced later)
- golang-1.8 <not-affected> (Vulnerable code introduced later)
- golang-1.7 <not-affected> (Vulnerable code introduced later)
Introduced in: (go1.14beta1)
Fixed by:

Search for package or bug name: Reporting problems