CVE-2020-28469

NameCVE-2020-28469
DescriptionThis affects the package glob-parent before 5.1.2. The enclosure regex used to check for strings ending in enclosure containing path separator.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-glob-parent (PTS)stretch3.0.1-1vulnerable
buster3.1.0-1+deb10u1fixed
bullseye5.1.1+~5.1.0-2fixed
bookworm, sid6.0.2+~5.1.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-glob-parentsourcestretch(unfixed)end-of-life
node-glob-parentsourcebuster3.1.0-1+deb10u1
node-glob-parentsource(unstable)5.1.1+~5.1.0-2

Notes

[stretch] - node-glob-parent <end-of-life> (Nodejs in stretch not covered by security support)
https://snyk.io/vuln/SNYK-JS-GLOBPARENT-1016905
https://github.com/gulpjs/glob-parent/commit/f9231168b0041fea3f8f954b3cceb56269fc6366

Search for package or bug name: Reporting problems