CVE-2020-28483

NameCVE-2020-28483
DescriptionThis affects all versions of package github.com/gin-gonic/gin. When gin is exposed directly to the internet, a client's IP can be spoofed by setting the X-Forwarded-For header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs988943

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-github-gin-gonic-gin (PTS)buster1.3.0+dfsg1-3vulnerable
bullseye1.6.3-3vulnerable
bookworm, sid1.6.3-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-github-gin-gonic-ginsource(unstable)(unfixed)988943

Notes

[bullseye] - golang-github-gin-gonic-gin <no-dsa> (Minor issue)
[buster] - golang-github-gin-gonic-gin <no-dsa> (Minor issue)
https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMGINGONICGIN-1041736
https://github.com/gin-gonic/gin/pull/2474
https://github.com/gin-gonic/gin/commit/c9ea8ece4a3881028f7f715f008414346a7f4b88

Search for package or bug name: Reporting problems