CVE-2020-28493

NameCVE-2020-28493
DescriptionThis affects the package jinja2 from 0.0.0 and before 2.11.3. The ReDoS vulnerability is mainly due to the `_punctuation_re regex` operator and its use of multiple wildcards. The last wildcard is the most exploitable as it searches for trailing punctuation. This issue can be mitigated by Markdown to format user content instead of the urlize filter, or by implementing request timeouts and limiting process memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs982736

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jinja2 (PTS)stretch2.8-1vulnerable
buster2.10-2vulnerable
bullseye2.11.2-1vulnerable
sid2.11.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jinja2source(unstable)2.11.3-1982736

Notes

[stretch] - jinja2 <no-dsa> (Minor issue)
https://github.com/pallets/jinja/pull/1343
https://snyk.io/vuln/SNYK-PYTHON-JINJA2-1012994

Search for package or bug name: Reporting problems