CVE-2020-28591

NameCVE-2020-28591
DescriptionAn out-of-bounds read vulnerability exists in the AMF File AMFParserContext::endElement() functionality of Slic3r libslic3r 1.3.0 and Master Commit 92abbc42. A specially crafted AMF file can lead to information disclosure. An attacker can provide a malicious file to trigger this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs985620

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slic3r (PTS)stretch1.2.9+dfsg-9~deb9u1fixed
buster1.3.0+dfsg1-3vulnerable
bullseye, sid1.3.0+dfsg1-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slic3rsourcestretch(not affected)
slic3rsource(unstable)1.3.0+dfsg1-4unimportant985620

Notes

[stretch] - slic3r <not-affected> (Vulnerable code not present)
https://talosintelligence.com/vulnerability_reports/TALOS-2020-1215
https://github.com/slic3r/Slic3r/issues/5061
https://github.com/slic3r/Slic3r/pull/5063
Crash in enduser application, no security impact

Search for package or bug name: Reporting problems