CVE-2020-28928

NameCVE-2020-28928
DescriptionIn musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2474-1
Debian Bugs975365

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
musl (PTS)buster1.1.21-2vulnerable
bullseye1.2.2-1fixed
bookworm1.2.3-1fixed
sid, trixie1.2.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muslsourcestretch1.1.16-3+deb9u1DLA-2474-1
muslsource(unstable)1.2.2-1975365

Notes

[buster] - musl <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2020/11/20/4

Search for package or bug name: Reporting problems