CVE-2020-28941

NameCVE-2020-28941
DescriptionAn issue was discovered in drivers/accessibility/speakup/spk_ttyio.c in the Linux kernel through 5.9.9. Local attackers on systems with the speakup driver could cause a local denial of service attack, aka CID-d41227544427. This occurs because of an invalid free when the line discipline is used more than once.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2483-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.246-2fixed
buster, buster (security)4.19.171-2fixed
bullseye5.10.13-1fixed
sid5.10.19-1fixed
linux-4.19 (PTS)stretch (security)4.19.171-2~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch(not affected)
linuxsourcebuster4.19.160-1
linuxsource(unstable)5.9.11-1
linux-4.19sourcestretch4.19.160-2~deb9u1DLA-2483-1

Notes

[stretch] - linux <not-affected> (Vulnerable code not present)
https://www.openwall.com/lists/oss-security/2020/11/19/3

Search for package or bug name: Reporting problems