CVE-2020-29040

NameCVE-2020-29040
DescriptionAn issue was discovered in Xen through 4.14.x allowing x86 HVM guest OS users to cause a denial of service (stack corruption), cause a data leak, or possibly gain privileges because of an off-by-one error. NOTE: this issue is caused by an incorrect fix for CVE-2020-27671.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs976109

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster4.11.4+37-g3263f257ca-1fixed
buster (security)4.11.4+57-g41a822c392-2fixed
bullseye, sid4.14.0+88-g1d1d1f5391-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcestretch(not affected)
xensourcebuster(not affected)
xensource(unstable)4.14.0+88-g1d1d1f5391-1976109

Notes

[buster] - xen <not-affected> (Patches for XSA-346 not applied)
[stretch] - xen <not-affected> (Patches for XSA-346 not applied)
https://xenbits.xen.org/xsa/advisory-355.html
Issue introduced by changes for XSA-346.

Search for package or bug name: Reporting problems