DescriptionAn issue was discovered in Xen through 4.14.x allowing x86 HVM guest OS users to cause a denial of service (stack corruption), cause a data leak, or possibly gain privileges because of an off-by-one error. NOTE: this issue is caused by an incorrect fix for CVE-2020-27671.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs976109

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch (security),
buster (security)4.11.4+107-gef32c7afa2-1fixed
bookworm, bullseye4.14.2+25-gb6a8c4f72d-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcestretch(not affected)
xensourcebuster(not affected)


[buster] - xen <not-affected> (Patches for XSA-346 not applied)
[stretch] - xen <not-affected> (Patches for XSA-346 not applied)
Issue introduced by changes for XSA-346.

Search for package or bug name: Reporting problems