CVE-2020-29510

NameCVE-2020-29510
DescriptionThe encoding/xml package in Go versions 1.15 and earlier does not correctly preserve the semantics of directives during tokenization round-trips, which allows an attacker to craft inputs that behave in conflicting ways during different stages of processing in affected downstream applications.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang-1.11 (PTS)buster, buster (security)1.11.6-1+deb10u4vulnerable
golang-1.15 (PTS)bullseye, sid1.15.9-6vulnerable
golang-1.7 (PTS)stretch1.7.4-2+deb9u1vulnerable
stretch (security)1.7.4-2+deb9u3vulnerable
golang-1.8 (PTS)stretch1.8.1-1+deb9u1vulnerable
stretch (security)1.8.1-1+deb9u3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golang-1.11source(unstable)(unfixed)unimportant
golang-1.15source(unstable)(unfixed)unimportant
golang-1.7source(unstable)(unfixed)
golang-1.8source(unstable)(unfixed)

Notes

[stretch] - golang-1.8 <ignored> (deemed unfixable by upstream who shifts responsibility to saml packages we don't ship)
[stretch] - golang-1.7 <ignored> (deemed unfixable by upstream who shifts responsibility to saml packages we don't ship)
https://github.com/golang/go/issues/43168
https://mattermost.com/blog/coordinated-disclosure-go-xml-vulnerabilities/
Upstream considers this WONTFIX and requires validation/updates in potentially affected SAML libs

Search for package or bug name: Reporting problems