CVE-2020-29651

NameCVE-2020-29651
DescriptionA denial of service via regular expression in the py.path.svnwc component of py (aka python-py) through 1.9.0 could be used by attackers to cause a compute-time denial of service attack by supplying malicious input to the blame functionality.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pypy (PTS)stretch5.6.0+dfsg-4vulnerable
buster7.0.0+dfsg-3vulnerable
bullseye, sid7.3.3+dfsg-1vulnerable
pypy3 (PTS)buster7.0.0+dfsg-3vulnerable
bullseye, sid7.3.3+dfsg-2vulnerable
python-py (PTS)stretch1.4.32-3vulnerable
buster1.7.0-2vulnerable
bullseye, sid1.10.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pypysource(unstable)(unfixed)
pypy3source(unstable)(unfixed)
python-pysource(unstable)(unfixed)

Notes

[stretch] - python-py <postponed> (Minor issue)
[stretch] - pypy <postponed> (Minor issue)
https://github.com/pytest-dev/py/issues/256
https://github.com/pytest-dev/py/pull/257
https://github.com/pytest-dev/py/commit/4a9017dc6199d2a564b6e4b0aa39d6d8870e4144

Search for package or bug name: Reporting problems