CVE-2020-35475

NameCVE-2020-35475
DescriptionIn MediaWiki before 1.35.1, the messages userrights-expiry-current and userrights-expiry-none can contain raw HTML. XSS can happen when a user visits Special:UserRights but does not have rights to change all userrights, and the table on the left side has unchangeable groups in it. (The right column with the changeable groups is not affected and is escaped correctly.)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4816-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3fixed
stretch (security)1:1.27.7-1~deb9u10fixed
buster, buster (security)1:1.31.16-1~deb10u1fixed
bullseye (security), bullseye1:1.35.4-1~deb11u1fixed
bookworm, sid1:1.35.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcestretch(not affected)
mediawikisourcebuster1:1.31.12-1~deb10u1DSA-4816-1
mediawikisource(unstable)1:1.35.1-1

Notes

[stretch] - mediawiki <not-affected> (Introduced in 1.29)
https://phabricator.wikimedia.org/T268917
https://lists.wikimedia.org/pipermail/wikitech-l/2020-December/094126.html

Search for package or bug name: Reporting problems