CVE-2020-35479

NameCVE-2020-35479
DescriptionMediaWiki before 1.35.1 allows XSS via BlockLogFormatter.php. Language::translateBlockExpiry itself does not escape in all code paths. For example, the return of Language::userTimeAndDate is is always unsafe for HTML in a month value. This affects MediaWiki 1.12.0 and later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2504-1, DSA-4816-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3vulnerable
stretch (security)1:1.27.7-1~deb9u7fixed
buster1:1.31.10-1~deb10u1vulnerable
buster (security)1:1.31.12-1~deb10u1fixed
bullseye, sid1:1.35.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcestretch1:1.27.7-1~deb9u7DLA-2504-1
mediawikisourcebuster1:1.31.12-1~deb10u1DSA-4816-1
mediawikisource(unstable)1:1.35.1-1

Notes

https://phabricator.wikimedia.org/T268938
https://lists.wikimedia.org/pipermail/wikitech-l/2020-December/094126.html

Search for package or bug name: Reporting problems