CVE-2020-35511

NameCVE-2020-35511
DescriptionA global buffer overflow was discovered in pngcheck function in pngcheck-2.4.0(5 patches applied) via a crafted png file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pngcheck (PTS)buster2.3.0-7+deb10u1vulnerable
bullseye2.3.0-13vulnerable
bookworm, sid3.0.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pngchecksource(unstable)(unfixed)

Notes

http://www.libpng.org/pub/png/apps/pngcheck.html
https://bugzilla.suse.com/show_bug.cgi?id=1202662#c2

Search for package or bug name: Reporting problems